Employee can log in via web, but can't log in through app


As the title implies, one of our employees is unable to log in via app. Of course, we have made sure to use the employee tab (have tried the admin tab too), and confirmed the validity of the login credentials too. I suspect there is a bug.

Device: iphone 11

Thank You

Can you show me the screen message when your employee cannot login?

Isn’t it obvious? just check if username and password are correct.

Thanks for your help, we have resolved the issue.

The password wasn’t incorrect actually. Apparently, the password contained – (two dashes) and for some reason, the application doesn’t use the exact same - as web (or something weird?). Anyway, after changing the password, it started working on both web and app. It’s really weird.

For reference, here is the problematic part of the old password:

Do you mean that using the same problematic password, you can login via web, but cannot do so via app? (which app is it? Android or iOS)

Precisely, it lets me through on web, but not on the apps, although I’m copy pasting the password in both cases. I have tried both Android and iOS.

Thanks for sharing your findings, I managed to track down the source of this issue, it’s due to special characters.

I will see what I can do about it later.

1 Like