Decimal separators and Labels on Payslip

Please correct me if I have not set it up correctly to have the following in place.

  1. Decimal Separators in Numbers
    It would be good to have commas for the amount in Payslips, especially for other currencies.
    It is currently showing: IDR 10000000.00
    Instead of: IDR 10,000,000.00
    OR: IDR 10.000.000,00 (based on their format)

It gets hard to read otherwise.

  1. Label on the Payslip
    My employee is set to be Indonesian. I have filled in their National ID which is correct. However, it is labelled as Passport when it is shown on the payslip.

Thank you for your time.

  1. Sorry that decimal separators are not supported yet, may be at a later stage.

  2. Is your home country set to Indonesia?

Yes it is.

I think you may have set something wrong.


  1. Your home country is Indonesia
  2. Your employees are Indonesian

Then the payslip will show National ID instead of passport.

Passport is only shown for expatriates that come from a country which is not the same as the home country.

I have just double-checked that:

  1. Home country is Indonesian
  2. Employee is Indonesian
  3. National ID is filled
  4. Passport is blank
  5. Payslip shows National ID values labelled as Passport

Also, my employees are from all over southeast Asia. The majority of them are in Indonesia, I’m based in Malaysia, and some are in the Philippines. It would be great if I could have more control over what shows on the payslip.


  1. Have you tried reprocessing or processing a new one? If your previous setting was incorrect, the processed payslip won’t reflect new changes unless reprocessed. Meanwhile, I just tested, I cannot repeat your problem, that’s why I think you may have made wrong setting in your last process. Try reprocess again.

  2. You may also sign up another test account to test a single employee just to make sure that you could repeat the same problem.

  3. Sorry, what else fields do you need to show on payslip?

Additionally, “Home Country” was the country you chose when you sign up for your Employer account, not the one you set in your Employer contact information.

“Home Country” cannot be changed once your Employer account is created.

The Home country (can’t be changed) and Employee country was not changed from the start. I will try to create another account for testing purposes later and update.

I have tested a new account and yes it is showing correctly. It still doesn’t solve why my existing one is not behaving the same way though as the settings are exactly the same.

As for the payslip, it would be good to be able to show fields that are related to the things employees require to see as confirmation of any change to their employment such as “Designation” or job title as well as the things they need for their own financial purposes such as “Joined Date”. Additional fields that would be useful are for them to expect the payment to go through so “Payment Date”.


  1. only has one logic to determine whether to show National ID or passport, i.e. whether the employee is an expatriate. As such, I strongly suggest that you check all the settings again, including the Home Country field in Employer->Information. After that, try to reprocess, or process a new payroll to see if it works.

  2. May I know why “Joined Date” is important in the payslip?


  1. I have shared screenshots to show you how I have tried to figure this out to no avail.

  2. In most banking situations, they would usually ask to prove that they have been employed in the company for more than X months. If they are not able to, they are required to ask for a Certificate of Employment that shows these dates.

  1. Have you reprocessed the payroll? Better still, delete the payroll and process again.

  2. Noted with thanks.

That’s a brand new payroll process created for this test.

Noted with thanks.

While I was checking my source code, it just occurred to me, have you ever changed the translated message of National ID for English? i.e. changed it to Passport for testing?

No, I have not touched the language editor or settings.

1 Like

It’s very strange, the code is very straight forward, and the only condition is to check if employee nationality is the same as employer home country.

I would imagine so. Perhaps the reference to the home country is not as expected?

It’s impossible, as Home Country is a field that will not be updated at all after account creation. Plus, you and I are not able to repeat it in your new test account, and my existing account.

I have tested on an employee who is based in Singapore. It shows up as National ID instead of Passport on the payslip.

I suspect that maybe if the initial creation of the account is Singapore and was changed to Indonesia, the reference of it sticks to Singapore. I can’t recall exactly but maybe 2 years ago, this change was requested?

I have not used the payroll feature until this month, therefore only noticed it during this month’s payroll run.